<!DOCTYPE html>
<!--[if lte IE 6]><html dir="ltr" lang="en-US" class="ie ie6"><![endif]-->
<!--[if IE 7]><html	 dir="ltr" lang="en-US" class="ie ie7"><![endif]-->
<!--[if IE 8]><html	 dir="ltr" lang="en-US" class="ie ie8"><![endif]-->
<!--[if IE 9]><html	 dir="ltr" lang="en-US" class="ie ie9"><![endif]-->
<!--[if !IE]>--><html dir="ltr" lang="en-US"><!--<![endif]--><head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1, minimum-scale=1">
<meta name="google-site-verification" content="KjqhH4ajF_p4Qmmm-KL0ZXBhlOmc1nCXkLWpmPKTYBU" />
<title>Trailer Watch: Kyle Henry&#8217;s Rogers Park | Filmmaker Magazine</title>
<!--[if IE]><script src="https://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<!--[if ! lte IE 6]><!-->
<link href="/wp-content/themes/filmmaker/stylesheets/filmmaker.css" rel="stylesheet" type="text/css">
<link media="all and (max-width: 600px)" href="/wp-content/themes/filmmaker/stylesheets/mobile.css" rel="stylesheet" type="text/css">
<link media="all and (max-width: 600px)" href="/wp-content/themes/filmmaker/stylesheets/foundation.css" rel="stylesheet" type="text/css">
<!--<![endif]-->
<!--[if lte IE 6]>
	<link rel="stylesheet" href="https://universal-ie6-css.googlecode.com/files/ie6.1.1.css" media="screen, projection">
	<![endif]-->
<!--[if IE 8]><meta http-equiv="X-UA-Compatible" content="IE=7" /><![endif]-->
<link rel="shortcut icon" href="https://filmmakermagazine.com/wp-content/themes/filmmaker/images/favicon.ico" />
<link rel="icon" type="image/vnd.microsoft.icon" href="https://filmmakermagazine.com/wp-content/themes/filmmaker/images/favicon.ico" />

<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://filmmakermagazine.com/wp-content/themes/filmmaker/images/icons/apple-touch-icon-precomposed.png">
<script src="//code.jquery.com/jquery-1.10.1.min.js"></script>
<link rel="stylesheet" href="/wp-content/themes/filmmaker/stylesheets/pikabu.css">
<style type="text/css">.m-pikabu-sidebar.m-pikabu-left, .m-pikabu-overlay, .m-pikabu-left-visible .m-pikabu-left, .m-pikabu-left-visible .m-pikabu-left, m-pikabu-container, .f-dropdown, .hide-for-medium-up, .show-for-small-only {display:none}</style>
<script src="https://use.typekit.net/egx0vqw.js"></script>
<script>try{Typekit.load({ async: true });}catch(e){}</script>

<meta name="keywords" content="kyle henry,rogers park,trailers" />

<link rel='dns-prefetch' href='//ssl.p.jwpcdn.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Filmmaker Magazine &raquo; Feed" href="https://filmmakermagazine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Filmmaker Magazine &raquo; Comments Feed" href="https://filmmakermagazine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Filmmaker Magazine &raquo; Trailer Watch: Kyle Henry&#8217;s Rogers Park Comments Feed" href="https://filmmakermagazine.com/105290-trailer-watch-kyle-henrys-rogers-park/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/filmmakermagazine.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dashicons-css' href='https://filmmakermagazine.com/wp-includes/css/dashicons.min.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css' href='https://filmmakermagazine.com/wp-includes/js/thickbox/thickbox.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='easingslider-css' href='https://filmmakermagazine.com/wp-content/plugins/easing-slider/assets/css/public.min.css?ver=3.0.8' type='text/css' media='all' />
<link rel='stylesheet' id='gglcptch-css' href='https://filmmakermagazine.com/wp-content/plugins/google-captcha/css/gglcptch.css?ver=1.35' type='text/css' media='all' />
<script type='text/javascript' src='https://filmmakermagazine.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-content/plugins/easing-slider/assets/js/public.min.js?ver=3.0.8'></script>
<script type='text/javascript' src='https://ssl.p.jwpcdn.com/6/8/jwplayer.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-content/themes/filmmaker/javascripts/plugins/fm_quicksearch.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/modernizr/2.8.3/modernizr.min.js?ver=2.8.3'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/foundation/5.5.2/js/foundation/foundation.js?ver=5.5.2'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/foundation/5.5.2/js/foundation/foundation.dropdown.js?ver=5.5.2'></script>
<link rel='https://api.w.org/' href='https://filmmakermagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://filmmakermagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://filmmakermagazine.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='&#8220;It&#8217;s about the Barriers to Justice that Exist when you are Poor and Up Against a Foreign Superpower&#8221;: PJ Raval on Call Her Ganda' href='https://filmmakermagazine.com/105287-its-about-the-barriers-to-justice-that-exist-when-you-are-poor-and-up-against-a-foreign-fuperpower-pj-raval-on-call-her-ganda/' />
<meta name="generator" content="WordPress 4.9.5" />
<link rel='shortlink' href='https://filmmakermagazine.com/?p=105290' />
<link rel="alternate" type="application/json+oembed" href="https://filmmakermagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffilmmakermagazine.com%2F105290-trailer-watch-kyle-henrys-rogers-park%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://filmmakermagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffilmmakermagazine.com%2F105290-trailer-watch-kyle-henrys-rogers-park%2F&#038;format=xml" />
<meta property="fb:pages" content="20175393984" />
<meta property="ia:markup_url" content="https://filmmakermagazine.com/105290-trailer-watch-kyle-henrys-rogers-park/?ia_markup=1" />
<script type="text/javascript">jwplayer.defaults = { "ph": 2 };</script><meta property="fb:admins" content="themedaglia" />
<meta property="fb:pages" content="20175393984" />
<meta property="og:title" content="Trailer Watch: Kyle Henry&#8217;s Rogers Park | Filmmaker Magazine" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://filmmakermagazine.com/105290-trailer-watch-kyle-henrys-rogers-park/" />
<meta property="og:site_name" content="Filmmaker Magazine" />
<meta property="og:description" content="A slightly belated posting here to recognize 25 New Face filmmaker Kyle Henry's latest feature, the Chicago-set relationship drama Rogers Park, which is extended at Cinema Village through this coming Thursday, May 10. After theatrical openings in New York and L.A., the film has cemented a rare 100% rating on Rotten Tomatoes, with Glenn Kenny writing in the New York Times, " The superb actors, given opportunities to go for broke, make each one count, and make the movie worth watching." Henry has been in the independent trenches for nearly two decades, with features including the superb psychological drama Room and the provocative sex-themed anthology film Fourplay. While the New York run winds down, Rogers Park is available for purchase and rent on iTunes." />
<meta name="description" content="A slightly belated posting here to recognize 25 New Face filmmaker Kyle Henry's latest feature, the Chicago-set relationship drama Rogers Park, which is extended at Cinema Village through this coming Thursday, May 10. After theatrical openings in New York and L.A., the film has cemented a rare 100% rating on Rotten Tomatoes, with Glenn Kenny writing in the New York Times, " The superb actors, given opportunities to go for broke, make each one count, and make the movie worth watching." Henry has been in the independent trenches for nearly two decades, with features including the superb psychological drama Room and the provocative sex-themed anthology film Fourplay. While the New York run winds down, Rogers Park is available for purchase and rent on iTunes." />
<meta name="author" content="Scott Macaulay" />
<meta property="og:image" content="https://filmmakermagazine.com/wp-content/uploads/2018/05/Blowin-Up-7-628x348.jpg" />
</head>
<body class="has_leaderboard">
<script type="text/javascript">
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-2872170-1']);
			_gaq.push(['_trackPageview']);
			(function() {
			  var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			  ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			})();
		</script>
<div class="m-pikabu-sidebar m-pikabu-left show-for-small-only">


<div class="col-1 features row sidebar-news-mobile">
<h2 class="sidebartitle"><a href="#" style="color:#fff">Latest News</a></h2>
<div id="sideblock">
<div class="sidefeature" data-behavior="feature_click large-6 columns">
<a href="https://filmmakermagazine.com/105235-how-to-deliver-your-film-to-a-festival-2018-edition/" class="img">
<img width="620" height="348" src="https://filmmakermagazine.com/wp-content/uploads/2015/10/projbooth-620x348.jpg" class="attachment-feature size-feature wp-post-image" alt="" srcset="https://filmmakermagazine.com/wp-content/uploads/2015/10/projbooth.jpg 620w, https://filmmakermagazine.com/wp-content/uploads/2015/10/projbooth-213x120.jpg 213w" sizes="(max-width: 620px) 100vw, 620px" /> <span>A portable projectionist cart intended for festival use with a DCP server, HDCAM player and Blu-ray Player</span> </a>
<h3><a href="https://filmmakermagazine.com/105235-how-to-deliver-your-film-to-a-festival-2018-edition/">How to Deliver Your Film to a Festival (2018 Edition)</a></h3>
<p class="meta">May 1, 2018</p>
<a href="https://filmmakermagazine.com/105206-you-really-had-to-struggle-to-get-your-music-olivier-assayas-on-cold-waters-long-journey-to-american-screens/" class="img">
<img width="628" height="348" src="https://filmmakermagazine.com/wp-content/uploads/2018/04/cold-628x348.jpg" class="attachment-feature size-feature wp-post-image" alt="" /> <span><em>Cold Water</em></span> </a>
<h3><a href="https://filmmakermagazine.com/105206-you-really-had-to-struggle-to-get-your-music-olivier-assayas-on-cold-waters-long-journey-to-american-screens/">&#8220;You Really Had to Struggle to Get Your Music&#8221;: Olivier Assayas on <em>Cold Water</em>&#8216;s Long Journey to American Screens</a></h3>
<p class="meta">Apr 26, 2018</p>
<a href="https://filmmakermagazine.com/105197-back-to-one-episode-two-emily-mortimer-talks-her-breakout-film-being-right-and-wrong-for-the-part-and-aaron-sorkin/" class="img">
<img width="628" height="348" src="https://filmmakermagazine.com/wp-content/uploads/2018/04/Phantom-Cowboys-2-628x348.jpg" class="attachment-feature size-feature wp-post-image" alt="" /> <span>Emily Mortimer (Photo: Peter Ash Lee)</span> </a>
<h3><a href="https://filmmakermagazine.com/105197-back-to-one-episode-two-emily-mortimer-talks-her-breakout-film-being-right-and-wrong-for-the-part-and-aaron-sorkin/">Back to One, Episode Two: Emily Mortimer talks Her Breakout Film, Being Right and Wrong for the Part, and Aaron Sorkin</a></h3>
<p class="meta">Apr 24, 2018</p>
</div>
<ul class="listing-articles" data-behavior="listing_click">
<li>
<a href="https://filmmakermagazine.com/105290-trailer-watch-kyle-henrys-rogers-park/">
<img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2018/05/Blowin-Up-7-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /> <b>Trailer Watch: Kyle Henry&#8217;s <i>Rogers Park</i></b>
</a>
<span>May 5, 2018</span>
</li>
<li>
<a href="https://filmmakermagazine.com/105287-its-about-the-barriers-to-justice-that-exist-when-you-are-poor-and-up-against-a-foreign-fuperpower-pj-raval-on-call-her-ganda/">
<img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2018/05/Blowin-Up-5-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /> <b>&#8220;It&#8217;s about the Barriers to Justice that Exist when you are Poor and Up Against a Foreign Superpower&#8221;: PJ Raval on <em>Call Her Ganda</em></b>
</a>
<span>May 5, 2018</span>
</li>
<li>
<a href="https://filmmakermagazine.com/105242-play-it-to-the-bone-new-titles-from-warner-archive-and-more-jim-hemphills-weekend-viewing-recommendations/">
<img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2018/05/play-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /> <b><em>Play It to the Bone</em>, New Titles from Warner Archive and More: Jim Hemphill&#8217;s Weekend Viewing Recommendations</b>
</a>
<span>May 4, 2018</span>
</li>
<li>
<a href="https://filmmakermagazine.com/105244-ifp-and-seriesfest-launch-development-initiative-for-independent-creators/">
<img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2018/05/ifpseriesfest-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /> <b>IFP and Seriesfest Launch Development Initiative for Independent Creators</b>
</a>
<span>May 3, 2018</span>
</li>
<li>
<a href="https://filmmakermagazine.com/105231-do-not-be-daunted-by-the-magnitude-of-the-challenge-in-front-of-you-assia-boundaoui-on-her-surveillance-doc-the-feeling-of-being-watched/">
<img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2018/04/Blowin-Up-4-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /> <b>&#8220;Do Not Be Daunted by the Magnitude of the Challenge in Front of You&#8221;: Assia Boundaoui on Her Surveillance Doc, <em>The Feeling of Being Watched</em></b>
</a>
<span>May 2, 2018</span>
</li>
<li>
<a href="https://filmmakermagazine.com/105236-fighting-eventfulness-deficit-at-the-2018-san-francisco-international-film-festival/">
<img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2018/05/Maddin_byPamelaGentile_005-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /> <b>Fighting Eventfulness Deficit at the 2018 San Francisco International Film Festival</b>
</a>
<span>May 1, 2018</span>
</li>
<li>
<a href="https://filmmakermagazine.com/105190-story-journalism-tabitha-jackson-and-joaquin-alvarado-talk-documentary-safety-and-security-at-cphdox/">
<img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2018/04/1999-1-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /> <b>Story + Journalism: Tabitha Jackson and Joaquin Alvarado Talk Documentary Safety and Security at CPH:DOX</b>
</a>
<span>May 1, 2018</span>
</li>
<li>
<a href="https://filmmakermagazine.com/105225-americans-love-the-story-of-saving-people-stephanie-wang-breal-on-her-complex-doc-about-prostitution-blowin-up/">
<img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2018/04/Blowin-Up-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /> <b>&#8220;Americans Love the Story of Saving People&#8221;: Stephanie Wang-Breal on Her Complex Prostitution Doc, <i>Blowin&#8217; Up</i></b>
</a>
<span>May 1, 2018</span>
</li>
<li>
<a href="https://filmmakermagazine.com/105232-back-to-one-episode-three-joshua-leonard-talks-acting-in-improvised-films-acting-in-iphone-films-and-too-many-bad-guys/">
<img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2018/05/Blowin-Up-3-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /> <b>Back to One, Episode Three: Joshua Leonard Talks Acting in Improvised Films, Acting in iPhone Films and Too Many Bad Guys</b>
</a>
<span>May 1, 2018</span>
</li>
</ul>
</div>
</div>

</div>
<div id="fm" class="m-pikabu-container detail generic-detail">
<header>
<div class="c">
<h1><a href="/">Filmmaker</a></h1>
<p><a href="https://filmmakermagazine.com/issues/spring-2018/">Click here to read our spring 2018 issue, featuring nterviews with <em>The Rider</em>'s Chloé Zhao, our special section on locations, David Leitner on 8K and more...</a></p>

<nav id="mobile-nav" class="mobile mobar show-for-small-only" role="navigation" data-topbar>
<section class="mobile-nav-section">
<ul class="left mobile-nav-left">
<li><a class="m-pikabu-nav-toggle" data-role="left"></a></li>
</ul>
<a href="http://filmmakermagazine.com/" class="mobile-nav-logo"><span class="title-area"></span></a>
<ul class="right mobile-nav-right">
<li><a class="search stoggle" data-role="left"></a>
<li><a href="https://account.filmmakermagazine.com/login?redirectTo=https://filmmakermagazine.com/105290-trailer-watch-kyle-henrys-rogers-park/"><span class="visuallyhidden">Log In</span></a></li>
<li><a class="navicon mtoggle" href="#"></a></li>
</ul>
</section>
</nav>

<nav data-behavior="main_nav" class="show-for-medium-up">
<ul>
<li class="n_1">
<a href="/category/filmmaking">Filmmaking</a>
<div class="subnav">
<ul>
<li><a href="/category/filmmaking">All</a></li>
<li><a href="/category/filmmaking/directing">Directing</a></li>
<li><a href="/category/filmmaking/screenwriting">Screenwriting</a></li>
<li><a href="/category/filmmaking/Cinematography">Cinematography</a></li>
<li><a href="/category/filmmaking/production">Production</a></li>
<li><a href="/category/filmmaking/post-production">Post-Production</a></li>
<li><a href="/category/filmmaking/financing">Financing</a></li>
<li><a href="/category/filmmaking/distribution">Distribution</a></li>
<li><a href="/category/filmmaking/transmedia">Transmedia</a></li>
</ul>
</div>
</li>
<li class="n_2">
<a href="/columns">Columns</a>
<div class="subnav subnav-double subnav-triple subnav-quadruple">
<ul>
<li><a href="/columns">All</a></li>
<li><a href="/column/focal-point/">Focal Point</a></li>
<li><a href="/column/shutter-angles/">Shutter Angles</a></li>
<li><a href="/column/film-reviews-by-howard-feinstein/">True Crit</a></li>
<li><a href="/column/continue-watching/">Continue Watching</a></li>
<li><a href="/column/the-editors-blog/">Editor's Blog</a></li>
<li><a href="/column/the-week-in-cameras/">The Week In Cameras</a></li>
<li><a href="/column/culture-hacker/">Culture Hacker</a></li>
<li><a href="/column/persona-project/">Persona Project</a></li>
<li><a href="/column/blue-velvet-project/">Blue Velvet Project</a></li>
<li><a href="/column/lady-vengeance/">Lady Vengeance</a></li>
<li><a href="/column/shooting-with-john/">Shooting With John</a></li>
<li><a href="/column/this-is-where-you-work/">This is Where You Work</a></li>
<li><a href="/column/microbudget-conversation/">Microbudget Conversation</a></li>
<li><a href="/column/into-the-splice/">Into the Splice</a></li>
<li><a href="/column/hammer-to-nail-2/">H2N Pick of the Week</a></li>
<li><a href="/column/industry-beat/">Industry Beat</a>
<li><a href="/column/extra-curricular/">Extra Curricular</a>
<li><a href="/column/time-and-tempo/">Time and Tempo</a>
<li><a href="/column/things-dps-dont-talk-about/">Things DPs Don't Talk About</a></li>
<li><a href="/column/notes-on-real-life/">Notes on Real Life</a>
</ul>
</div>
</li>
<li class="n_3">
<a href="/category/festivals-events/">Festivals &amp; Events</a>
<div class="subnav">
<ul>
<li><a href="/category/sundance/">Sundance</a></li>
<li><a href="/category/sxsw/">SXSW</a></li>
<li><a href="/category/festivals-events/">All Festivals &amp; Events</a></li>
</ul>
</div>
</li>
<li class="n_4">
<a href="/category/interviews">Interviews</a>
<div class="subnav">
<ul>
<li><a href="/category/interviews">All</a></li>
<li><a href="/category/interviews/directors">Directors</a></li>
<li><a href="/category/interviews/actors">Actors</a></li>
<li><a href="/category/interviews/screenwriters">Screenwriters</a></li>
<li><a href="/category/interviews/cinematographers">Cinematographers</a></li>
<li><a href="/category/interviews/editors">Editors</a></li>
<li><a href="/series/25-new-faces-of-independent-film-2017/">25 New Faces</a></li>
</ul>
</div>
</li>
<li class="n_5"><a href="/videos">Videos</a></li>
<li class="n_6"><a href="https://filmmakermagazine.com/issues/spring-2018/">Latest Issue</a></li>
<li style="width: 160px; ">
<section style="" id="fm_quicksearch_form">
<form role="search" method="get" id="searchform" action="/">
<input name="s" id="fm_quicksearch" type="text" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'" />
<input id="fm_quicksearch-btn" type="submit" value="">
</form>
</section>
</li>
<li><a href="http://twitter.com/FilmmakerMag" class="tw" target="_blank">Twitter</a></li>
<li><a href="http://www.facebook.com/FilmmakerMagazine" class="fb" target="_blank">Facebook</a></li>
<li><a href="/feed" class="rss">RSS</a></li>
</ul>
</nav>
</div>
</header>
<nav id="tools">
<ul class="c">
<li><a href="http://www.ifp.org/" target="_blank">ifp.org</a></li>
<li class="current"><a href="/">Filmmaker Magazine</a></li>
<li><a href="http://gotham.ifp.org/" target="_blank">Gotham Awards</a></li>
<li><a href="/new-faces-of-independent-film/">25 New Faces</a></li>
<li class="a-login">
<a href="https://account.filmmakermagazine.com/login?redirectTo=https://filmmakermagazine.com/105290-trailer-watch-kyle-henrys-rogers-park/">Log in</a>
</li>
</li>
<li class="a-login"><a href="http://ifp.org/join" target="_blank">Join IFP</a></li>
<li class="a-login"><a href="/contact" target="_blank">Contact us by email</a></li>
<li class="a-login"><a href="https://visitor.r20.constantcontact.com/d.jsp?llr=lt9xkwbab&p=oi&m=1101334833771&sit=xuqv5wpbb&f=01fd798c-b447-479e-8b8f-1b5ff541cfcf" target="_blank">Subscribe to Newsletter</a></li>
<li class="a-login">
<a href="https://account.filmmakermagazine.com/subscribe" target="_blank">Subscribe</a>
</li>
</ul>
</nav>
<div class="banner hide-for-small-only">


<ins data-revive-zoneid="649" data-revive-ct0="%c" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
<script async src="//flow.aquaplatform.com/asyncjs.php"></script>
</div>

<div id="searchtoggle" style="display:none">
<section style="" id="fm_quicksearch_form">
<form role="search" method="get" id="searchform" action="/">
<input name="s" value="Search" id="fm_quicksearch" type="text">
<input id="fm_quicksearch-btn" type="submit" value="">
</form>
</section>
</div>
<ul id="mmenu" style="display:none">
<li></li>
<li><a href="/category/filmmaking">Filmmaking</a></li>
<li><a href="/columns">Columns</a></li>
<li><a href="/category/festivals-events">Festivals &amp; Events</a></li>
<li><a href="/category/interviews">Interviews</a></li>
<li><a href="/videos">Videos</a></li>
<li><a href="https://filmmakermagazine.com/issues/spring-2018/">Current Issue</a></li>
<li><a href="/series/25-new-faces-film-2016">25 New Faces</a></li>
<li>
<ul class="mmenusub">
<li><a href="https://account.filmmakermagazine.com/subscribe">Subscribe</a></li>
<li><a href="/advertise">Advertise</a></li>
<li><a href="/support">Support</a></li>
</ul>
<ul class="mmenusub">
<li><a href="/archive">Issue Archive</a></li>
<li><a href="/privacy-policy">Privacy policy</a></li>
<li><a href="/contact">Contact</a></li>
</ul>
<div class="clear" />
</li>
<li>
<div class="mmenufoot">
<span>Filmmaker magazine is a publication of<br />
<img src="/wp-content/themes/filmmaker/images/ifp.png" width="34px"><br>
<a href="http://www.ifp.org/">click here to learn more</a>.</span>
</div>
</li>
<li>
<div class="mmenusocial">
<a href="https://twitter.com/FilmmakerMag" class="twitter"></a><a href="https://www.facebook.com/FilmmakerMagazine" class="facebook"></a>
</div>
</li>
<li></li>
</ul>
<div class='dropdown-ad-container'></div> <div class="hide-for-medium-up mobile-leaderboard">

<ins data-revive-zoneid="903" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
<script async src="//flow.aquaplatform.com/asyncjs.php"></script>
</div>
<article class="content c cols-2x">
<a class="colback show-for-small-only" href="#" onclick="history.back();return false;"><img src="/wp-content/themes/filmmaker/images/back.png">Back to selection</a>
<h1>Trailer Watch: Kyle Henry&#8217;s <i>Rogers Park</i></h1>
<div class="col-1">
<div class="img">
<iframe src="https://player.vimeo.com/video/232376978?byline=0&portrait=0" width="620" height="349" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>
<p><a href="https://vimeo.com/232376978">Rogers Park - Official Trailer</a> from <a href="https://vimeo.com/fourplayflim">Kyle Henry</a> on <a href="https://vimeo.com">Vimeo</a>.</p> </div>
<div class="meta">
<p>
by <a href="https://filmmakermagazine.com/author/scott/" title="Posts by Scott Macaulay" rel="author">Scott Macaulay</a> <br>in <a href="https://filmmakermagazine.com/category/filmmaker-videos/" rel="category tag">Filmmaker Videos</a><br />
on May 5, 2018 </p>
<p class="tags">
<a href="https://filmmakermagazine.com/tag/kyle-henry/" rel="tag">Kyle Henry</a>, <a href="https://filmmakermagazine.com/tag/rogers-park/" rel="tag">Rogers Park</a>, <a href="https://filmmakermagazine.com/tag/trailers/" rel="tag">Trailers</a> </p>
<p></p>
</div>
<p>A slightly belated posting here to recognize <a href="https://filmmakermagazine.com/archives/issues/summer2005/features/25_faces1-5.php">25 New Face filmmaker Kyle Henry&#8217;s</a> latest feature, the Chicago-set relationship drama <em>Rogers Park</em>, which is extended at Cinema Village through this coming Thursday, May 10. After theatrical openings in New York and L.A., the film has cemented a rare 100% rating on Rotten Tomatoes, with<a href="https://www.nytimes.com/2018/04/26/movies/review-rogers-park.html"> Glenn Kenny writing in the New York Times</a>, &#8220;The superb actors, given opportunities to go for broke, make each one count, and make the movie worth watching.&#8221; Henry has been in the independent trenches for nearly two decades, with features including the superb psychological drama Room and the provocative sex-themed anthology film <em>Fourplay</em>. While the New York run winds down, Rogers Park is <a href="https://itunes.apple.com/us/movie/rogers-park/id1364849963?mt=6&#038;ign-mpt=uo%3D4">available for purchase and rent on iTunes. </a></p>
<figure class="mobile_content_box hide-for-medium-up"><iframe sandbox='allow-scripts allow-popups allow-popups-to-escape-sandbox' id='ac010cbe' name='ac010cbe' src='https://flow.aquaplatform.com/afr.php?n=ac010cbe&amp;zoneid=641&amp;cb=%n&amp;ct0=%c' frameborder='0' scrolling='no' width='100%' height='100%' layout='responsive' allowfullscreen='' style='width:100%'><a href='https://flow.aquaplatform.com/ck.php?n=a16beeb9&amp;cb=%n' target='_blank'><img src='https://flow.aquaplatform.com/avw.php?zoneid=641&amp;cb=%n&amp;n=a16beeb9&amp;ct0=%c' border='0' alt='' /></a></iframe>
<script type='text/javascript' src='https://flow.aquaplatform.com/ag.php'></script></figure><p></p>
<aside class="comments">
<div id="disqus_thread"></div>

</aside>
</div>
<div class="col-2">
<aside class="box_ad">

<ins data-revive-zoneid="645" data-revive-ct0="%c" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
<script async src="//flow.aquaplatform.com/asyncjs.php"></script>
</aside>
<aside class="related-articles">
<h1>Related Articles</h1>
<ul class="listing-articles" data-behavior="listing_click">
<li>
<a href="https://filmmakermagazine.com/105228-watch-laura-mosss-fry-day/">
<div class="hidicon show-for-small-only"><img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2018/04/Blowin-Up-2-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /></div>
<b>Watch: Laura Moss&#8217;s <i>Fry Day</i></b>
</a>
<span>
by <a href="https://filmmakermagazine.com/author/scott/" title="Posts by Scott Macaulay" rel="author">Scott Macaulay</a> in <a href="https://filmmakermagazine.com/category/filmmaker-videos/" rel="category tag">Filmmaker Videos</a><br>
Apr 30, 2018 </span>
</li>
<li>
<a href="https://filmmakermagazine.com/105210-take-me-back-to-that-day-if-you-could-errol-morriss-wrenching-distracted-driving-shorts/">
<div class="hidicon show-for-small-only"><img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2018/04/Phantom-Cowboys-3-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /></div>
<b>&#8220;Take Me Back to That Day, If You Could&#8221;: Errol Morris&#8217;s Wrenching Distracted Driving Shorts</b>
</a>
<span>
by <a href="https://filmmakermagazine.com/author/scott/" title="Posts by Scott Macaulay" rel="author">Scott Macaulay</a> in <a href="https://filmmakermagazine.com/category/filmmaker-videos/" rel="category tag">Filmmaker Videos</a><br>
Apr 27, 2018 </span>
</li>
<li>
<a href="https://filmmakermagazine.com/105127-watch-zodiacs-commitment-to-historical-accuracy/">
<div class="hidicon show-for-small-only"><img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2018/04/Screen-Shot-2018-04-10-at-11.56.49-AM-300x172.png" class="attachment-small size-small wp-post-image" alt="" /></div>
<b>Watch: <em>Zodiac</em>&#8216;s Commitment to Historical Accuracy</b>
</a>
<span>
by <a href="https://filmmakermagazine.com/author/filmmakerstaff/" title="Posts by Filmmaker Staff" rel="author">Filmmaker Staff</a> in <a href="https://filmmakermagazine.com/category/filmmaker-videos/" rel="category tag">Filmmaker Videos</a><br>
Apr 10, 2018 </span>
</li>
</ul>
</aside>
<div class="banner">
</div>
<div class="banner">

<ins data-revive-zoneid="646" data-revive-ct0="%c" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
<script async src="//flow.aquaplatform.com/asyncjs.php"></script>
</div>
<div class="banner">
</div>
</div>
<aside class="featured-articles">

<div class="leaderboard2 hide-for-small-only">
<ins data-revive-zoneid="2131" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
<script async src="//flow.aquaplatform.com/asyncjs.php"></script>
</div>
<h1>Featured Articles</h1>
<ul class="listing-articles" data-behavior="listing_click">
<li>
<a href="https://filmmakermagazine.com/85600-you-have-to-laugh/">
<img width="220" height="120" src="https://filmmakermagazine.com/wp-content/uploads/2014/04/robespierre-online-crop-220x120.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://filmmakermagazine.com/wp-content/uploads/2014/04/robespierre-online-crop-220x120.jpg 220w, https://filmmakermagazine.com/wp-content/uploads/2014/04/robespierre-online-crop-380x206.jpg 380w" sizes="(max-width: 220px) 100vw, 220px" /> <b>You Have To Laugh</b>
</a>
<span>By <a href="https://filmmakermagazine.com/author/sarah-salovaara/" title="Posts by Sarah Salovaara" rel="author">Sarah Salovaara</a> on Apr 28, 2014</span>
</li>
<li>
<a href="https://filmmakermagazine.com/94547-im-very-aware-that-in-the-movies-i-love-there-is-no-one-who-looks-like-me-lauren-domino-on-producing-in-new-orleans/">
<img width="220" height="120" src="https://filmmakermagazine.com/wp-content/uploads/2015/06/Lipsky-1-220x120.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://filmmakermagazine.com/wp-content/uploads/2015/06/Lipsky-1-220x120.jpg 220w, https://filmmakermagazine.com/wp-content/uploads/2015/06/Lipsky-1-380x206.jpg 380w" sizes="(max-width: 220px) 100vw, 220px" /> <b>&#8220;I’m Very Aware That in the Movies I Love There is No One Who Looks Like Me&#8221;: Lauren Domino on Producing in New Orleans</b>
</a>
<span>By <a href="https://filmmakermagazine.com/author/taylor-hess/" title="Posts by Taylor Hess" rel="author">Taylor Hess</a> on Jun 9, 2015</span>
</li>
<li>
<a href="https://filmmakermagazine.com/53396-crowdfunding-the-unsustainable-truth/">
<img width="220" height="120" src="https://filmmakermagazine.com/wp-content/uploads/2012/10/Crowdfunding-220x120.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://filmmakermagazine.com/wp-content/uploads/2012/10/Crowdfunding-220x120.jpg 220w, https://filmmakermagazine.com/wp-content/uploads/2012/10/Crowdfunding-380x206.jpg 380w" sizes="(max-width: 220px) 100vw, 220px" /> <b>Crowdfunding: The Unsustainable Truth</b>
</a>
<span>By <a href="https://filmmakermagazine.com/author/terry-green/" title="Posts by Terry Green" rel="author">Terry Green</a> on Oct 15, 2012</span>
</li>
<li>
<a href="https://filmmakermagazine.com/75755-be-natural-interview-with-documentary-filmmakers-pamela-green-and-jarik-van-sluijs/">
<img width="220" height="120" src="https://filmmakermagazine.com/wp-content/uploads/2013/08/BeNaturalfeatured-220x120.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://filmmakermagazine.com/wp-content/uploads/2013/08/BeNaturalfeatured-220x120.jpg 220w, https://filmmakermagazine.com/wp-content/uploads/2013/08/BeNaturalfeatured-380x206.jpg 380w" sizes="(max-width: 220px) 100vw, 220px" /> <b><i>Be Natural</i>: Interview with documentary filmmakers Pamela Green and Jarik van Sluijs</b>
</a>
<span>By <a href="https://filmmakermagazine.com/author/michaelmurie/" title="Posts by Michael Murie" rel="author">Michael Murie</a> on Aug 26, 2013</span>
</li>
</ul>
</aside>
<aside class="social mobilesocial" data-behavior="social_links">
<ul>
<li class="tw">
<a href="http://twitter.com/share" class="twitter-share-button" data-text="" data-count="horizontal" data-via="FilmmakerMag">Tweet</a>
</li>
<li class="fb">
<div class="fb-like" data-send="false" data-layout="button_count" data-width="100" data-show-faces="true"></div>
</li>
<li class="su">
<a href="http://www.addthis.com/bookmark.php?v=300&amp;pubid=fmmag" class="addthis_button">Share this post</a>
</li>
<li class="cs">
<span>Comments</span>
</li>
</ul>
</aside>
</article>
<footer>
<div class="c small-10 small-text-center grid-content">
<h1><a href="/">The Magazine of Independent Film</a></h1>
<small>&copy;2018 Filmmaker Magazine &nbsp; All Rights Reserved &nbsp; A Publication of <span class="ifp">IFP</span></small>
<ul class="small-centered">
<li><a href="https://account.filmmakermagazine.com/subscribe">Subscribe</a></li>
<li><a href="/archive">Issue Archive</a></li>
<li><a href="/advertise/">Advertise</a></li>
<li><a href="/privacy-policy">Privacy Policy</a></li>
<li><a href="/support">Support</a></li>
<li><a href="/contact">Contact Us</a></li>
<li class="credit"><a href="http://www.area17.com/?utm_source=filmmakermagazine.com&utm_medium=referral&utm_campaign=footer-credit" target="_blank">Site by AREA 17</a></li>
</ul>
</div>
</footer>
<div class="mobilecredit clearfix small-11 show-for-small-only small-centered">
<span class="left">
&copy; 2018 Filmmaker Magazine<br>All Rights Reserved
</span>
<span class="right">
A Publication of IPF
</span>
</div>
<!--[if lte IE 6]>
    		<div id="ie6">
    			<p>This website does <strong>not</strong> fully support Internet Explorer 6. Your general web browsing experience will be much improved if you upgrade for free to <a href="http://www.microsoft.com/windows/products/winfamily/ie/default.mspx">Internet Explorer 7, Internet Explorer 8</a> or <a href="www.google.com/chrome">Google Chrome</a>.</p>
    		</div>
    		<![endif]-->
</div>
<script>var addthis_config = { data_track_addressbar:true };</script>
<script src="/wp-content/themes/filmmaker/javascripts/vendor/jquery.uniform.min.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/plugins/slider.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/plugins/validate.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/application.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/behaviors/main_nav.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/behaviors/social_links.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/behaviors/mask_email.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/behaviors/older_newer.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/behaviors/latest_news_popular_tabs.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/behaviors/hero_features.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/behaviors/listing_click.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/behaviors/feature_click.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/behaviors/strip_close.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/behaviors/accordion.js"></script>
<script src="/wp-content/themes/filmmaker/javascripts/behaviors/uniform.js"></script>
<script type="text/javascript" src="//static.filmmakermagazine.com/js/pikabu.js"></script>
<script>
      $(function() {
        pikabu = new Pikabu({
    		  widths: {
            left: 'calc(100% - 40px)'
          }
        });
      });
    </script>
<script type="text/javascript">
    	jQuery(document).ready(function($) {
    		$("#mmenu").hide();
    		$(".mtoggle").click(function() {
    			$("#mmenu").slideToggle(500);
    		});
    	});
    </script>
<script type="text/javascript">
    	jQuery(document).ready(function($) {
    		$("#searchtoggle").hide();
    		$(".stoggle").click(function() {
    			$("#searchtoggle").slideToggle(500);
    		});
    	});
    </script>

<ins data-revive-zoneid="705" data-revive-ct0="%c" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
<script async src="//flow.aquaplatform.com/asyncjs.php"></script><link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/fancybox/2.1.5/jquery.fancybox.min.css" media="screen" />
<script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/fancybox/2.1.5/jquery.fancybox.pack.js"></script>
<ins data-revive-zoneid="638" data-revive-ct0="%c" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
<script async src="//flow.aquaplatform.com/asyncjs.php"></script>
<div id="fb-root"></div>
<script>(function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_GB/all.js#xfbml=1&appId=422939121081837";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));</script>
<script type="text/javascript">
    	FM.is_logged_in = false;
    </script>
<script>
      (function(d, t, id) {
        GWI = { config: {} }
        var js, _s = d.getElementsByTagName(t)[0];
        if (d.getElementById(id)) return;
        js = d.createElement(t);
        js.id = id;
        js.src= '//superwidget.gowatchit.com/gwi.js';

        GWI.config.apiKey = 'd0f59baadadd3349e4a9b2674bcceae8';
        GWI.config.theme = 'default';

        _s.parentNode.insertBefore(js, _s);
      }(document, 'script', 'gwijslib'));
    </script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/filmmakermagazine.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"filmmakermagazine"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.15'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.15"},"disqusIdentifier":"105290 http:\/\/filmmakermagazine.com\/?p=105290","disqusShortname":"filmmakermagazine","disqusTitle":"Trailer Watch: Kyle Henry\u2019s <i>Rogers Park<\/i>","disqusUrl":"https:\/\/filmmakermagazine.com\/105290-trailer-watch-kyle-henrys-rogers-park\/","postId":"105290"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.15'></script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>
<script>
      $ = jQuery.noConflict(true);
      (function($) {
        $(document).foundation();
      });
    </script>
<a class="thickbox thickbox_auto_open" href="/main/ads/home-overlay.php?secs=10&ad_height=580&ad_width=640&zone=636&TB_iframe=true&modal=true" data-height="510" data-width="650"></a>
</body>
</html>
