<!DOCTYPE html>
<!--[if lte IE 6]><html dir="ltr" lang="en-US" class="ie ie6"><![endif]-->
<!--[if IE 7]><html	 dir="ltr" lang="en-US" class="ie ie7"><![endif]-->
<!--[if IE 8]><html	 dir="ltr" lang="en-US" class="ie ie8"><![endif]-->
<!--[if IE 9]><html	 dir="ltr" lang="en-US" class="ie ie9"><![endif]-->
<!--[if !IE]>--><html dir="ltr" lang="en-US"><!--<![endif]--><head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1, minimum-scale=1">
<meta name="google-site-verification" content="KjqhH4ajF_p4Qmmm-KL0ZXBhlOmc1nCXkLWpmPKTYBU" />
<title>Clip Premiere: Luigi Campi&#8217;s My First Kiss and the People Involved | Filmmaker Magazine</title>
<!--[if IE]><script src="https://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<!--[if ! lte IE 6]><!-->
<link href="/wp-content/themes/filmmaker/stylesheets/filmmaker.css" rel="stylesheet" type="text/css">
<link media="all and (max-width: 600px)" href="/wp-content/themes/filmmaker/stylesheets/mobile.css" rel="stylesheet" type="text/css">
<link media="all and (max-width: 600px)" href="/wp-content/themes/filmmaker/stylesheets/foundation.css" rel="stylesheet" type="text/css">
<!--<![endif]-->
<!--[if lte IE 6]>
	<link rel="stylesheet" href="https://universal-ie6-css.googlecode.com/files/ie6.1.1.css" media="screen, projection">
	<![endif]-->
<!--[if IE 8]><meta http-equiv="X-UA-Compatible" content="IE=7" /><![endif]-->
<link rel="shortcut icon" href="https://filmmakermagazine.com/wp-content/themes/filmmaker/images/favicon.ico" />
<link rel="icon" type="image/vnd.microsoft.icon" href="https://filmmakermagazine.com/wp-content/themes/filmmaker/images/favicon.ico" />

<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://filmmakermagazine.com/wp-content/themes/filmmaker/images/icons/apple-touch-icon-precomposed.png">
<script src="//code.jquery.com/jquery-1.10.1.min.js"></script>
<style type="text/css">.f-dropdown, .hide-for-medium-up, .show-for-small-only {display:none}</style>
<script src="https://use.typekit.net/egx0vqw.js"></script>
<script>try{Typekit.load({ async: true });}catch(e){}</script>

<meta name="keywords" content="bobbi salvör menuez,filmatique,luigi campi,my first kiss and the people involved" />
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://filmmakermagazine.com/#organization","url":"https://filmmakermagazine.com/","name":"Filmmaker Magazine","sameAs":[]},{"@type":"WebSite","@id":"https://filmmakermagazine.com/#website","url":"https://filmmakermagazine.com/","name":"Filmmaker Magazine","publisher":{"@id":"https://filmmakermagazine.com/#organization"}},{"@type":"WebPage","@id":"https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/#webpage","url":"https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/","inLanguage":"en-US","name":"Clip Premiere: Luigi Campi&#8217;s <i>My First Kiss and the People Involved</i>","isPartOf":{"@id":"https://filmmakermagazine.com/#website"},"image":{"@type":"ImageObject","@id":"https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/#primaryimage","url":"https://filmmakermagazine.com/wp-content/uploads/2019/11/My-First-Kiss.jpg","width":1237,"height":696,"caption":"<i>My First Kiss and the People Involved</i>"},"primaryImageOfPage":{"@id":"https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/#primaryimage"},"datePublished":"2019-11-05T17:00:08+00:00","dateModified":"2019-11-05T18:09:58+00:00"},{"@type":"Article","@id":"https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/#article","isPartOf":{"@id":"https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/#webpage"},"author":{"@id":"https://filmmakermagazine.com/author/scott/#author"},"headline":"Clip Premiere: Luigi Campi&#8217;s <i>My First Kiss and the People Involved</i>","datePublished":"2019-11-05T17:00:08+00:00","dateModified":"2019-11-05T18:09:58+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/#webpage"},"publisher":{"@id":"https://filmmakermagazine.com/#organization"},"articleSection":"Filmmaking, Bobbi Salv\u00f6r Menuez, Filmatique, Luigi Campi, My First Kiss and the People Involved","image":{"@type":"ImageObject","@id":"https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/#primaryimage","url":"https://filmmakermagazine.com/wp-content/uploads/2019/11/My-First-Kiss.jpg","width":1237,"height":696,"caption":"<i>My First Kiss and the People Involved</i>"}},{"@type":"Person","@id":"https://filmmakermagazine.com/author/scott/#author","name":"Scott Macaulay","sameAs":[],"image":{"@type":"ImageObject","@id":"https://filmmakermagazine.com/#personlogo","url":"https://secure.gravatar.com/avatar/12d9f348db168841499222c1004f2166?s=96&d=mm&r=g","width":96,"height":96,"caption":"Scott Macaulay"}}]}</script>

<link rel='dns-prefetch' href='//ssl.p.jwpcdn.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Filmmaker Magazine &raquo; Feed" href="https://filmmakermagazine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Filmmaker Magazine &raquo; Comments Feed" href="https://filmmakermagazine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Filmmaker Magazine &raquo; Clip Premiere: Luigi Campi&#8217;s My First Kiss and the People Involved Comments Feed" href="https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/feed/" />
<link rel='stylesheet' id='dashicons-css' href='https://filmmakermagazine.com/wp-includes/css/dashicons.min.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css' href='https://filmmakermagazine.com/wp-includes/js/thickbox/thickbox.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://filmmakermagazine.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='easingslider-css' href='https://filmmakermagazine.com/wp-content/plugins/easing-slider/assets/css/public.min.css?ver=3.0.8' type='text/css' media='all' />
<script type='text/javascript' src='https://filmmakermagazine.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-content/plugins/easing-slider/assets/js/public.min.js?ver=3.0.8'></script>
<script type='text/javascript' src='https://ssl.p.jwpcdn.com/6/8/jwplayer.js?ver=5.2.4'></script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-content/themes/filmmaker/javascripts/plugins/fm_quicksearch.js?ver=5.2.4'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/modernizr/2.8.3/modernizr.min.js?ver=2.8.3'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/foundation/5.5.2/js/foundation/foundation.js?ver=5.5.2'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/foundation/5.5.2/js/foundation/foundation.dropdown.js?ver=5.5.2'></script>
<link rel='https://api.w.org/' href='https://filmmakermagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://filmmakermagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://filmmakermagazine.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Back to One, Episode 82: Dorian Missick' href='https://filmmakermagazine.com/108502-back-to-one-episode-82-dorian-missick/' />
<meta name="generator" content="WordPress 5.2.4" />
<link rel='shortlink' href='https://filmmakermagazine.com/?p=108504' />
<link rel="alternate" type="application/json+oembed" href="https://filmmakermagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffilmmakermagazine.com%2F108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://filmmakermagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffilmmakermagazine.com%2F108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved%2F&#038;format=xml" />
<meta property="fb:pages" content="20175393984" />
<meta property="ia:markup_url" content="https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/?ia_markup=1" />
<script type="text/javascript">jwplayer.defaults = { "ph": 2 };</script><meta property="fb:admins" content="themedaglia" />
<meta property="fb:pages" content="20175393984" />
<meta property="og:title" content="Clip Premiere: Luigi Campi&#8217;s My First Kiss and the People Involved | Filmmaker Magazine" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/" />
<meta property="og:site_name" content="Filmmaker Magazine" />
<meta property="og:description" content="Premiering in New York this Thursday in a one-time event prior to its free streaming launch the next day is Luigi Campi's coming-of-age thriller My First Kiss and the People Involved. Starring Bobbi Salvör Menuez, it's the tale of a quiet, recessive young woman (Menuez) living in a group home who goes on the hunt for her missing caregiver. Said Campi in a Filmmaker interview, "The film’s tension arises when violent events that she can’t fully grasp force her to step out of her safe zone. My first connection was to the main character’s unique way of seeing the world, and that perspective guided every choice we made: camera, casting, location, shots. It’s not a film from the outside — about a group home. It’s a story from the inside, from Sam’s point of view, and we live the journey with her. We only know what she knows, and we feel what she feels, which is a great place to be in a mystery story."

The filmmakers have given Filmmaker a clip from the film, which is below along with the trailer. The live event will take place Thursday, November 7 at 7:30 PM at the Wild Project in the East Village. Tickets are available at the link. The following day the film will screen free on Filmatique, which screens one picture per week from "new directors and celebrated auteurs" to audiences in the U.S. and Canada. Said Filmatique head curator Ursula Grisham in a press release, "My First Kiss and the People Involved is an auspicious debut from Luigi Campi that harnesses rich sensory detail and evocative storytelling techniques to achieve one of Filmatique's principal goals—championing stories about protagonists and perspectives you would not typically see on screen. We are thrilled to be hosting the film's digital premiere."

On November 17, the film will be available on Amazon Prime in the U.S. and Canada.


My First Kiss and the People Involved - Clip 1 - Kiss from Luigi Campi on Vimeo.


My First Kiss and the People Involved - Trailer from Luigi Campi on Vimeo."/>
<meta name="description" content="Premiering in New York this Thursday in a one-time event prior to its free streaming launch the next day is Luigi Campi's coming-of-age thriller My First Kiss and the People Involved. Starring Bobbi Salvör Menuez, it's the tale of a quiet, recessive young woman (Menuez) living in a group home who goes on the hunt for her missing caregiver. Said Campi in a Filmmaker interview, "The film’s tension arises when violent events that she can’t fully grasp force her to step out of her safe zone. My first connection was to the main character’s unique way of seeing the world, and that perspective guided every choice we made: camera, casting, location, shots. It’s not a film from the outside — about a group home. It’s a story from the inside, from Sam’s point of view, and we live the journey with her. We only know what she knows, and we feel what she feels, which is a great place to be in a mystery story."

The filmmakers have given Filmmaker a clip from the film, which is below along with the trailer. The live event will take place Thursday, November 7 at 7:30 PM at the Wild Project in the East Village. Tickets are available at the link. The following day the film will screen free on Filmatique, which screens one picture per week from "new directors and celebrated auteurs" to audiences in the U.S. and Canada. Said Filmatique head curator Ursula Grisham in a press release, "My First Kiss and the People Involved is an auspicious debut from Luigi Campi that harnesses rich sensory detail and evocative storytelling techniques to achieve one of Filmatique's principal goals—championing stories about protagonists and perspectives you would not typically see on screen. We are thrilled to be hosting the film's digital premiere."

On November 17, the film will be available on Amazon Prime in the U.S. and Canada.


My First Kiss and the People Involved - Clip 1 - Kiss from Luigi Campi on Vimeo.


My First Kiss and the People Involved - Trailer from Luigi Campi on Vimeo."/>
<meta name="author" content="Scott Macaulay"/>
<meta property="og:image" content="https://filmmakermagazine.com/wp-content/uploads/2019/11/My-First-Kiss-628x348.jpg"/>
	</head>
	<body class="has_leaderboard">

		<script type="text/javascript">
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-2872170-1']);
			_gaq.push(['_trackPageview']);
			(function() {
			  var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			  ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			})();
		</script>

		<div class="show-for-small-only">
			<!-- left sidebar content -->
					</div>

		<div id="fm" class="detail generic-detail">
			<header>

				<div class="c">
					<h1><a href="/">Filmmaker</a></h1>

										
												<p><a href="https://filmmakermagazine.com/issues/fall-2019/">Click here to read our Fall 2019 issue, featuring this year's 25 New Faces of Independent Film, <em>Parasite</em>'s Bong Joon-ho, Leo Goldsmith and Gregory Zinman on serving as experimental film consultants on <em>Ad Astra</em> and more...</a></p>
					  		
					
					<!-- Start Mobile Nav -->
					<nav id="mobile-nav" class="mobile mobar show-for-small-only" role="navigation" data-topbar>
						<section class="mobile-nav-section">
							<a href="http://filmmakermagazine.com/" class="mobile-nav-logo"><span class="title-area"></span></a>
							<ul class="right mobile-nav-right">
								<li><a class="search stoggle" data-role="left"></a>
																	<li><a href="https://account.filmmakermagazine.com/login?redirectTo=https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/"><span class="visuallyhidden">Log In</span></a></li>
																<li><a class="navicon mtoggle" href="#"></a></li>
							</ul>
						</section>
					</nav>
					<!-- End Mobile Nav -->

					<nav data-behavior="main_nav" class="show-for-medium-up">
						<ul>
							<li class="n_1">
								<a href="/category/filmmaking">Filmmaking</a>
								<div class="subnav">
									<ul>
										<li><a href="/category/filmmaking">All</a></li>
										<li><a href="/category/filmmaking/directing">Directing</a></li>
										<li><a href="/category/filmmaking/screenwriting">Screenwriting</a></li>
										<li><a href="/category/filmmaking/Cinematography">Cinematography</a></li>
										<li><a href="/category/filmmaking/production">Production</a></li>
										<li><a href="/category/filmmaking/post-production">Post-Production</a></li>
										<li><a href="/category/filmmaking/financing">Financing</a></li>
										<li><a href="/category/filmmaking/distribution">Distribution</a></li>
										<li><a href="/category/filmmaking/transmedia">Transmedia</a></li>
									</ul>
								</div>
							</li>
							<li class="n_2">
								<a href="/columns">Columns</a>
								<div class="subnav subnav-double subnav-triple subnav-quadruple">
									<ul>
										<li><a href="/columns">All</a></li>
										<li style="color:#fff;">Current Columns:</li>
										<li><a href="/column/focal-point/">Focal Point</a></li>
										<li><a href="/column/shutter-angles/">Shutter Angles</a></li>
										<li><a href="/column/back-to-one-a-podcast-on-acting/">Back to One</a>
										<li><a href="/column/continue-watching/">Continue Watching</a></li>
										<li><a href="/column/the-week-in-cameras/">The Week In Cameras</a></li>
										<li><a href="/column/notes-on-real-life/">Notes on Real Life</a>
										<li><a href="/column/persona-project/">Persona Project</a></li>
										<li><a href="/column/industry-beat/">Industry Beat</a>
										<li><a href="/column/extra-curricular/">Extra Curricular</a>
										<li><a href="/column/the-editors-blog/">Editor's Blog</a></li>
										<li style="color:#fff;">Archived Columns:</li>
										<li><a href="/column/blue-velvet-project/">Blue Velvet Project</a></li>
										<li><a href="/column/things-dps-dont-talk-about/">Things DPs Don't Talk About</a></li>
										<li><a href="/column/time-and-tempo/">Time and Tempo</a>
										<li><a href="/column/microbudget-conversation/">Microbudget Conversation</a></li>
										<li><a href="/column/film-reviews-by-howard-feinstein/">True Crit</a></li>
										<li><a href="/column/into-the-splice/">Into the Splice</a></li>
										<li><a href="/column/culture-hacker/">Culture Hacker</a></li>
										<li><a href="/column/lady-vengeance/">Lady Vengeance</a></li>
										<li><a href="/column/shooting-with-john/">Shooting With John</a></li>
										<li><a href="/column/hammer-to-nail-2/">H2N Pick of the Week</a></li>
										<li><a href="/column/this-is-where-you-work/">This is Where You Work</a></li>
									</ul>
								</div>
							</li>
							<li class="n_3">
								<a href="/category/festivals-events/">Festivals &amp; Events</a>
								<div class="subnav">
									<ul>
										<li><a href="/category/sundance/">Sundance</a></li>
										<li><a href="/category/sxsw/">SXSW</a></li>
										<li><a href="/category/festivals-events/">All Festivals &amp; Events</a></li>
									</ul>
								</div>
							</li>
							<li class="n_4">
								<a href="/category/interviews">Interviews</a>
								<div class="subnav">
									<ul>
										<li><a href="/category/interviews">All</a></li>
										<li><a href="/category/interviews/directors">Directors</a></li>
										<li><a href="/category/interviews/actors">Actors</a></li>
										<li><a href="/category/interviews/screenwriters">Screenwriters</a></li>
										<li><a href="/category/interviews/cinematographers">Cinematographers</a></li>
										<li><a href="/category/interviews/editors">Editors</a></li>
										<li><a href="/category/interviews/producers">Producers</a></li>
										<li><a href="/new-faces-of-independent-film/">25 New Faces</a></li>
									</ul>
								</div>
							</li>
							<li class="n_5"><a href="/videos">Videos</a></li>
							<li class="n_6"><a href="https://filmmakermagazine.com/issues/fall-2019/">Latest Issue</a></li>

							<li style="width: 160px; ">
								<section style="" id="fm_quicksearch_form">
									<form role="search" method="get" id="searchform" action="/">
										<input name="s" id="fm_quicksearch" type="text" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'" />
										<input id="fm_quicksearch-btn" type="submit" value="">
									</form>
								</section><!-- end fm_quicksearch_form -->
							</li>
							<li><a href="http://twitter.com/FilmmakerMag" class="tw" target="_blank">Twitter</a></li>
							<li><a href="http://www.facebook.com/FilmmakerMagazine" class="fb" target="_blank">Facebook</a></li>
							<li><a href="/feed" class="rss">RSS</a></li>
						</ul>
					</nav>
				</div>
			</header>

			<nav id="tools">
				<ul class="c">
					<li><a href="http://www.ifp.org/" target="_blank">ifp.org</a></li>
					<li class="current"><a href="/">Filmmaker Magazine</a></li>
					<li><a href="http://gotham.ifp.org/" target="_blank">Gotham Awards</a></li>
					<li><a href="/new-faces-of-independent-film/">25 New Faces</a></li>

													<li class="a-login">
								<a href="https://account.filmmakermagazine.com/login?redirectTo=https://filmmakermagazine.com/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved/">Log in</a>
							</li>
											</li>
					<li class="a-login"><a href="http://ifp.org/join" target="_blank">Join IFP</a></li>
					<li class="a-login"><a href="http://eepurl.com/glvMQb" target="_blank">Subscribe to Newsletter</a></li>
											<li class="a-login">
													<a href="https://account.filmmakermagazine.com/subscribe" target="_blank">Subscribe</a>
											</li>
				</ul>
			</nav>

			<div class="banner hide-for-small-only">
				<!--/* Default */-->
<!--/*
  *
  * Aqua Platform Ad Management Asynchronous JS Tag
  * - Generated with Revive Adserver v3.2.3
  * - Doubleclick/DFP
  *
  */-->
<ins data-revive-zoneid="649" data-revive-ct0="%c" data-revive-sync="2"
data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
<script async src="//flow.aquaplatform.com/asyncjs.php"></script>
			</div>

			<!-- MOBILE NAV MENU -->
			<div id="searchtoggle" style="display:none">
				<section style="" id="fm_quicksearch_form">
					<form role="search" method="get" id="searchform" action="/">
						<input name="s" value="Search" id="fm_quicksearch" type="text">
						<input id="fm_quicksearch-btn" type="submit" value="">
					</form>
				</section>
			</div>

			<ul id="mmenu" style="display:none">
				<li></li>
				<li><a href="/category/filmmaking">Filmmaking</a></li>
				<li><a href="/columns">Columns</a></li>
				<li><a href="/category/festivals-events">Festivals &amp; Events</a></li>
				<li><a href="/category/interviews">Interviews</a></li>
				<li><a href="/videos">Videos</a></li>
				<li><a href="https://filmmakermagazine.com/issues/fall-2019/">Current Issue</a></li>
				<li><a href="/series/25-new-faces-film-2019">25 New Faces</a></li>
				<li>
					<ul class="mmenusub">
						<li><a href="https://account.filmmakermagazine.com/subscribe">Subscribe</a></li>
						<li><a href="/advertise">Advertise</a></li>
						<li><a href="/support">Support</a></li>
					</ul>
					<ul class="mmenusub">
						<li><a href="/archive">Issue Archive</a></li>
						<li><a href="/privacy-policy">Privacy policy</a></li>
						<li><a href="https://account.filmmakermagazine.com/">View Print Magazines</a></li>
					</ul>
					<div class="clear" />
				</li>
				<li>
					<div class="mmenufoot">
						<span>Filmmaker magazine is a publication of<br />
						<img src="/wp-content/themes/filmmaker/images/ifp.png" width="34px"><br>
						<a href="http://www.ifp.org/">click here to learn more</a>.</span>
					</div>
				</li>
				<li>
					<div class="mmenusocial">
					<a href="https://twitter.com/FilmmakerMag" class="twitter"></a><a href="https://www.facebook.com/FilmmakerMagazine" class="facebook"></a>
					</div>
				</li>
				<li></li>
			</ul>

						<div class='dropdown-ad-container'></div>			<div class="hide-for-medium-up mobile-leaderboard">
  <!--/*
    *
    * Aqua Platform Ad Management Asynchronous JS Tag
    * - Generated with Revive Adserver v4.0.1
    *
    */-->

  <ins data-revive-zoneid="903" data-revive-sync="2" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
  <script async src="//flow.aquaplatform.com/asyncjs.php"></script>
</div>

  
<article class="content c cols-2x">
	<a class="colback show-for-small-only" href="#" onclick="history.back();return false;"><img src="/wp-content/themes/filmmaker/images/back.png">Back to selection</a>
	<h1>Clip Premiere: Luigi Campi&#8217;s <i>My First Kiss and the People Involved</i></h1>
	<div class="col-1">

							<div class="img">
				<img width="1237" height="696" src="https://filmmakermagazine.com/wp-content/uploads/2019/11/My-First-Kiss.jpg" class="attachment-full size-full wp-post-image" alt="" srcset="https://filmmakermagazine.com/wp-content/uploads/2019/11/My-First-Kiss.jpg 1237w, https://filmmakermagazine.com/wp-content/uploads/2019/11/My-First-Kiss-768x432.jpg 768w, https://filmmakermagazine.com/wp-content/uploads/2019/11/My-First-Kiss-1024x576.jpg 1024w, https://filmmakermagazine.com/wp-content/uploads/2019/11/My-First-Kiss-213x120.jpg 213w" sizes="(max-width: 1237px) 100vw, 1237px" />																	</div>
		
		<div class="meta">
			<p>
				by <a href="https://filmmakermagazine.com/author/scott/" title="Posts by Scott Macaulay" rel="author">Scott Macaulay</a> <br>in <a href="https://filmmakermagazine.com/category/filmmaking/" rel="category tag">Filmmaking</a><br/>
				on Nov 5, 2019			</p>
			<p class="tags">
				<a href="https://filmmakermagazine.com/tag/bobbi-salvor-menuez/" rel="tag">Bobbi Salvör Menuez</a>, <a href="https://filmmakermagazine.com/tag/filmatique/" rel="tag">Filmatique</a>, <a href="https://filmmakermagazine.com/tag/luigi-campi/" rel="tag">Luigi Campi</a>, <a href="https://filmmakermagazine.com/tag/my-first-kiss-and-the-people-involved/" rel="tag">My First Kiss and the People Involved</a>			</p>
			<p></p>
					</div>

		<p>Premiering in New York this Thursday in a one-time event prior to its free streaming launch the next day is Luigi Campi&#8217;s coming-of-age thriller <a href="http://www.myfirstkissmovie.com"><em>My First Kiss and the People Involved</em>.</a> Starring Bobbi Salvör Menuez, it&#8217;s the tale of a quiet, recessive young woman (Menuez) living in a group home who goes on the hunt for her missing caregiver. Said Campi <a href="https://filmmakermagazine.com/98756-five-questions-for-my-first-kiss-and-the-people-involved-writerdirector-luigi-campi/#.XcGZyy2ZN-U">in a <em>Filmmaker</em> interview,</a> &#8220;The film’s tension arises when violent events that she can’t fully grasp force her to step out of her safe zone. My first connection was to the main character’s unique way of seeing the world, and that perspective guided every choice we made: camera, casting, location, shots. It’s not a film from the outside — about a group home. It’s a story from the inside, from Sam’s point of view, and we live the journey with her. We only know what she knows, and we feel what she feels, which is a great place to be in a mystery story.&#8221;</p>
<p>The filmmakers have given <em>Filmmaker</em> a clip from the film, which is below along with the trailer. The live event will take place Thursday, November 7 at 7:30 PM at the Wild Project in the East Village. Tickets are available<a href="https://www.eventbrite.com/e/my-first-kiss-and-the-people-involved-tickets-78340776371"> at the link.</a> The following day the film will screen free on <a href="http://filmatique.com">Filmatique,</a> which screens one picture per week from &#8220;new directors and celebrated auteurs&#8221; to audiences in the U.S. and Canada. Said Filmatique head curator Ursula Grisham in a press release, &#8220;<em>My First Kiss and the People Involved</em> is an auspicious debut from Luigi Campi that harnesses rich sensory detail and evocative storytelling techniques to achieve one of Filmatique&#8217;s principal goals—championing stories about protagonists and perspectives you would not typically see on screen. We are thrilled to be hosting the film&#8217;s digital premiere.&#8221;</p>
<p>On November 17, the film will be available on Amazon Prime in the U.S. and Canada.</p>
<p><iframe src="https://player.vimeo.com/video/167646960?color=ffffff&#038;title=0&#038;byline=0&#038;portrait=0" width="640" height="360" frameborder="0" allow="autoplay; fullscreen" allowfullscreen></iframe></p>
<p><a href="https://vimeo.com/167646960">My First Kiss and the People Involved &#8211; Clip 1 &#8211; Kiss</a> from <a href="https://vimeo.com/user866236">Luigi Campi</a> on <a href="https://vimeo.com">Vimeo</a>.</p>
<p><iframe src="https://player.vimeo.com/video/365749058?color=ffffff&#038;title=0&#038;byline=0&#038;portrait=0" width="640" height="360" frameborder="0" allow="autoplay; fullscreen" allowfullscreen></iframe></p>
<p><a href="https://vimeo.com/365749058">My First Kiss and the People Involved &#8211; Trailer</a> from <a href="https://vimeo.com/user866236">Luigi Campi</a> on <a href="https://vimeo.com">Vimeo</a>.</p>
<figure class="mobile_content_box hide-for-medium-up"><iframe
  sandbox='allow-scripts allow-popups allow-popups-to-escape-sandbox'
  id='ac010cbe' name='ac010cbe' src='https://flow.aquaplatform.com/afr.php?n=ac010cbe&amp;zoneid=641&amp;sync=2&amp;cb=%n&amp;ct0=%c'
  frameborder='0' scrolling='no' width='100%' height='100%' layout='responsive' allowfullscreen=''
  style='width:100%'
  ><a href='https://flow.aquaplatform.com/ck.php?n=a16beeb9&amp;cb=%n' target='_blank'><img src='https://flow.aquaplatform.com/avw.php?zoneid=641&amp;cb=%n&amp;n=a16beeb9&amp;ct0=%c' border='0' alt='' /></a></iframe>
<script type='text/javascript' src='https://flow.aquaplatform.com/ag.php'></script></figure><p></p>
		
		<aside class="comments">
			
<div id="disqus_thread"></div>
			<!-- <div id="disqus_thread">
			</div> -->
					</aside>
	</div>
	<div class="col-2">

		<aside class="box_ad">
<!--/*
  *
  * Aqua Platform Ad Management Asynchronous JS Tag
  * - Generated with Revive Adserver v3.2.3
  * - Doubleclick/DFP
  *
  */-->

<ins data-revive-zoneid="645" data-revive-ct0="%c" data-revive-sync="2" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
<script async src="//flow.aquaplatform.com/asyncjs.php"></script>
</aside>

		<aside class="related-articles">
			<h1>Related Articles</h1>
			<ul class="listing-articles" data-behavior="listing_click">
											<li>
								<a href="https://filmmakermagazine.com/108466-strand-releasings-30-30-vision-premiering-new-iphone-shorts-by-ira-sachs-james-schamus-and-elisabeth-subrin/">
									<!-- IMG DISPLAYS ON MOBILE --><div class="hidicon show-for-small-only"><img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2019/10/Strand-at-30-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /></div><!-- END -->
									<b>Strand Releasing&#8217;s  &#8220;30/30 Vision&#8221;: Premiering New iPhone Shorts by Ira Sachs, James Schamus and Elisabeth Subrin</b>
								</a>
								<span>
									by <a href="https://filmmakermagazine.com/author/scott/" title="Posts by Scott Macaulay" rel="author">Scott Macaulay</a> in <a href="https://filmmakermagazine.com/category/filmmaker-videos/" rel="category tag">Filmmaker Videos</a>, <a href="https://filmmakermagazine.com/category/filmmaking/" rel="category tag">Filmmaking</a><br>
									Oct 22, 2019								</span>
							</li>
														<li>
								<a href="https://filmmakermagazine.com/108421-producer-reset-independent-producers-unplug-at-the-nevada-city-film-festival-filmmaker-residency/">
									<!-- IMG DISPLAYS ON MOBILE --><div class="hidicon show-for-small-only"><img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2019/10/Nevada-City-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /></div><!-- END -->
									<b>Producer Reset: Independent Producers Unplug at the Nevada City Film Festival Filmmaker Residency</b>
								</a>
								<span>
									by <a href="https://filmmakermagazine.com/author/scott/" title="Posts by Scott Macaulay" rel="author">Scott Macaulay</a> in <a href="https://filmmakermagazine.com/category/filmmaking/" rel="category tag">Filmmaking</a><br>
									Oct 21, 2019								</span>
							</li>
														<li>
								<a href="https://filmmakermagazine.com/108445-gemini-man-tax-credits-at-120fps/">
									<!-- IMG DISPLAYS ON MOBILE --><div class="hidicon show-for-small-only"><img width="300" height="172" src="https://filmmakermagazine.com/wp-content/uploads/2019/10/gm-300x172.jpg" class="attachment-small size-small wp-post-image" alt="" /></div><!-- END -->
									<b><em>Gemini Man</em>: Tax Credits at 120fps</b>
								</a>
								<span>
									by <a href="https://filmmakermagazine.com/author/vrizov/" title="Posts by Vadim Rizov" rel="author">Vadim Rizov</a> in <a href="https://filmmakermagazine.com/category/filmmaking/" rel="category tag">Filmmaking</a><br>
									Oct 16, 2019								</span>
							</li>
										</ul>
		</aside>

		<div class="banner">
					</div>

		<div class="banner">
			<!--/*
  *
  * Aqua Platform Ad Management Asynchronous JS Tag
  * - Generated with Revive Adserver v3.2.3
  * - Doubleclick/DFP
  *
  */-->

<ins data-revive-zoneid="646" data-revive-ct0="%c" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
<script async src="//flow.aquaplatform.com/asyncjs.php"></script>
		</div>

		<div class="banner">
					</div>

	</div>

	
<aside class="featured-articles">

  <!--/*
    *
    * Aqua Platform Ad Management Asynchronous JS Tag
    * - Generated with Revive Adserver v4.0.2
    *
    */-->
  <div class="leaderboard2 hide-for-small-only">
  <ins data-revive-zoneid="2131" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8" data-revive-sync="2"></ins>
  <script async src="//flow.aquaplatform.com/asyncjs.php"></script>
  </div>

  <h1>Featured Articles</h1>
  <ul class="listing-articles" data-behavior="listing_click">
        <li>
      <a href="https://filmmakermagazine.com/66853-critics-notebook-the-2013-sxsw-film-festival/">
        <img width="220" height="120" src="https://filmmakermagazine.com/wp-content/uploads/2013/03/Short_Term_12-220x120.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://filmmakermagazine.com/wp-content/uploads/2013/03/Short_Term_12-220x120.jpg 220w, https://filmmakermagazine.com/wp-content/uploads/2013/03/Short_Term_12-380x206.jpg 380w" sizes="(max-width: 220px) 100vw, 220px" />        <b>Critic&#8217;s Notebook: The 2013 SXSW Film Festival</b>
      </a>
      <span>By <a href="https://filmmakermagazine.com/author/brandon-harris/" title="Posts by Brandon Harris" rel="author">Brandon Harris</a> on Mar 13, 2013</span>
    </li>
        <li>
      <a href="https://filmmakermagazine.com/60479-can-independent-film-be-an-addiction/">
        <img width="220" height="120" src="https://filmmakermagazine.com/wp-content/uploads/2012/12/requiem-for-a-dream-pills11-220x120.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://filmmakermagazine.com/wp-content/uploads/2012/12/requiem-for-a-dream-pills11-220x120.jpg 220w, https://filmmakermagazine.com/wp-content/uploads/2012/12/requiem-for-a-dream-pills11-380x206.jpg 380w" sizes="(max-width: 220px) 100vw, 220px" />        <b>Can Independent Film Be an Addiction?</b>
      </a>
      <span>By <a href="https://filmmakermagazine.com/author/scott/" title="Posts by Scott Macaulay" rel="author">Scott Macaulay</a> on Dec 12, 2012</span>
    </li>
        <li>
      <a href="https://filmmakermagazine.com/84760-panasonic-commits-to-4k-announces-the-varicam-35/">
        <img width="220" height="120" src="https://filmmakermagazine.com/wp-content/uploads/2014/03/Varicam35Featured-220x120.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://filmmakermagazine.com/wp-content/uploads/2014/03/Varicam35Featured-220x120.jpg 220w, https://filmmakermagazine.com/wp-content/uploads/2014/03/Varicam35Featured-380x206.jpg 380w" sizes="(max-width: 220px) 100vw, 220px" />        <b>Panasonic Commits to 4K, Announces the VariCam 35</b>
      </a>
      <span>By <a href="https://filmmakermagazine.com/author/michaelmurie/" title="Posts by Michael Murie" rel="author">Michael Murie</a> on Mar 3, 2014</span>
    </li>
        <li>
      <a href="https://filmmakermagazine.com/77309-it-found-it-way-to-me-exclusively-because-of-the-title-alexander-payne-on-nebraska/">
        <img width="220" height="120" src="https://filmmakermagazine.com/wp-content/uploads/2013/11/nebraska-mic-220x120.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://filmmakermagazine.com/wp-content/uploads/2013/11/nebraska-mic-220x120.jpg 220w, https://filmmakermagazine.com/wp-content/uploads/2013/11/nebraska-mic-380x206.jpg 380w" sizes="(max-width: 220px) 100vw, 220px" />        <b>&#8220;It Found Its Way to Me Exclusively Because of the Title&#8221;: Alexander Payne on <i>Nebraska</i></b>
      </a>
      <span>By <a href="https://filmmakermagazine.com/author/atong/" title="Posts by Allan Tong" rel="author">Allan Tong</a> on Nov 20, 2013</span>
    </li>
      </ul>
</aside>


	<aside class="social mobilesocial" data-behavior="social_links">
		<ul>
			<li class="tw">
				<a href="http://twitter.com/share" class="twitter-share-button" data-text="" data-count="horizontal" data-via="FilmmakerMag">Tweet</a>
			</li>
			<li class="fb">
				<div class="fb-like" data-send="false" data-layout="button_count" data-width="100" data-show-faces="true"></div>
			</li>
			<li class="su">
				<a href="http://www.addthis.com/bookmark.php?v=300&amp;pubid=fmmag" class="addthis_button">Share this post</a>
			</li>
			<li class="cs">
				<span>Comments</span>
			</li>
		</ul>
	</aside>
</article>


            <footer>
                <div class="c small-10 small-text-center grid-content">
                    <h1><a href="/">The Magazine of Independent Film</a></h1>
                    <small>&copy;2019 Filmmaker Magazine &nbsp; All Rights Reserved &nbsp; A Publication of <span class="ifp">IFP</span></small>
                    <ul class="small-centered">
                        <li><a href="https://account.filmmakermagazine.com/subscribe">Subscribe</a></li>
                        <li><a href="/archive">Issue Archive</a></li>
                        <li><a href="/advertise/">Advertise</a></li>
                        <li><a href="/privacy-policy">Privacy Policy</a></li>
                        <li><a href="/support">Support</a></li>
                        <li><a href="/contact">Contact Us</a></li>
                        <li class="credit"><a href="http://www.area17.com/?utm_source=filmmakermagazine.com&utm_medium=referral&utm_campaign=footer-credit" target="_blank">Site by AREA 17</a></li>
                    </ul>
                </div>
            </footer>

            <div class="mobilecredit clearfix small-11 show-for-small-only small-centered">
                <span class="left">
                    &copy; 2019 Filmmaker Magazine<br>All Rights Reserved
                </span>
                <span class="right">
                    A Publication of IPF
                </span>
            </div>

            <!--[if lte IE 6]>
                <div id="ie6">
                    <p>This website does <strong>not</strong> fully support Internet Explorer 6. Your general web browsing experience will be much improved if you upgrade for free to <a href="http://www.microsoft.com/windows/products/winfamily/ie/default.mspx">Internet Explorer 7, Internet Explorer 8</a> or <a href="www.google.com/chrome">Google Chrome</a>.</p>
                </div>
            <![endif]-->
        </div>


        <script>var addthis_config = { data_track_addressbar:true };</script>

        <script src="/wp-content/themes/filmmaker/javascripts/vendor/jquery.uniform.min.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/plugins/slider.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/plugins/validate.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/application.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/behaviors/main_nav.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/behaviors/social_links.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/behaviors/mask_email.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/behaviors/older_newer.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/behaviors/latest_news_popular_tabs.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/behaviors/hero_features.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/behaviors/listing_click.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/behaviors/feature_click.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/behaviors/strip_close.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/behaviors/accordion.js"></script>
        <script src="/wp-content/themes/filmmaker/javascripts/behaviors/uniform.js"></script>

        <script type="text/javascript">
            jQuery(document).ready(function($) {
                $("#mmenu").hide();
                $(".mtoggle").click(function() {
                    $("#mmenu").slideToggle(500);
                });
            });
        </script>

        <script type="text/javascript">
            jQuery(document).ready(function($) {
                $("#searchtoggle").hide();
                $(".stoggle").click(function() {
                    $("#searchtoggle").slideToggle(200);
                });
            });
        </script>

<!-- page js -->

<ins data-revive-zoneid="705" data-revive-sync="2" data-revive-ct0="%c" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
<script async src="//flow.aquaplatform.com/asyncjs.php"></script><link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/fancybox/2.1.5/jquery.fancybox.min.css" media="screen" />
<script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/fancybox/2.1.5/jquery.fancybox.pack.js"></script><!--/*
  *
  * Aqua Platform Ad Management Asynchronous JS Tag
  * - Generated with Revive Adserver v3.2.3
  * - Doubleclick/DFP
  *
  */-->

<ins data-revive-zoneid="638" data-revive-ct0="%c" data-revive-sync="2" data-revive-id="5d3cba222eaaeee40162c5d04d22e1b8"></ins>
<script async src="//flow.aquaplatform.com/asyncjs.php"></script>
        <div id="fb-root"></div>
        <script>(function(d, s, id) {
            var js, fjs = d.getElementsByTagName(s)[0];
            if (d.getElementById(id)) return;
            js = d.createElement(s); js.id = id;
            js.src = "//connect.facebook.net/en_GB/all.js#xfbml=1&appId=422939121081837";
            fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));</script>

        <script type="text/javascript">
            FM.is_logged_in = false;
        </script>

        <script>
            (function(d, t, id) {
                GWI = { config: {} }
                var js, _s = d.getElementsByTagName(t)[0];
                if (d.getElementById(id)) return;
                js = d.createElement(t);
                js.id = id;
                js.src= '//superwidget.gowatchit.com/gwi.js';

                GWI.config.apiKey = 'd0f59baadadd3349e4a9b2674bcceae8';
                GWI.config.theme = 'default';

                _s.parentNode.insertBefore(js, _s);
            }(document, 'script', 'gwijslib'));
        </script>

<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/filmmakermagazine.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"filmmakermagazine"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"108504 http:\/\/filmmakermagazine.com\/?p=108504","disqusShortname":"filmmakermagazine","disqusTitle":"Clip Premiere: Luigi Campi\u2019s <i>My First Kiss and the People Involved<\/i>","disqusUrl":"https:\/\/filmmakermagazine.com\/108504-clip-premiere-luigi-campis-my-first-kiss-and-the-people-involved\/","postId":"108504"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://filmmakermagazine.com/wp-includes/js/wp-embed.min.js?ver=5.2.4'></script>
    <script>
      // js code for interstitial
      jQuery( document ).ready(function() {
          var width = jQuery(window).width();
          var url = jQuery('.thickbox_auto_open').attr('href');
          var height = 0;
          if (width > 660) {
            width = 660;
            height = 495;
          } else {
            width = 300;
            height = 262;
          }
          url = url + '&width=' + width + '&height=' + height;
          jQuery('.thickbox_auto_open').attr('href', url);
      });
    </script>

    <script type="text/javascript">
      jQuery(document).ready(function($) {
        if (!sessionStorage.interstitial_seen) {
          setTimeout(function(){
            jQuery('.thickbox_auto_open').click();
            $("#TB_overlay").click(tb_remove);
          }, 1000);
          sessionStorage.interstitial_seen = 1;
        }
      });
    </script>
        <script>
            jQuery(document).ready(function($) {
                $(document).foundation();
            });
        </script>

        <a class="thickbox thickbox_auto_open" href="/main/ads/home-overlay.php?secs=10&ad_height=580&ad_width=640&zone=636&sync=2&TB_iframe=true&modal=true" data-height="510" data-width="650"></a>
	</body>
</html>
